Service Status

Upgrade MLPF
Incident Report for Poniverse
Resolved
The forums are back on line and up to date.
Posted 8 months ago. Dec 21, 2017 - 02:44 PST
Update
Upgrading… please stand by.
Posted 8 months ago. Dec 21, 2017 - 02:04 PST
Investigating
MLPF is going offline for an upgrade! The upgrade will start at 1:50 AM PST (3:50 AM Central), and is expected to take about half an hour. The forum will be unavailable during that time.
Posted 8 months ago. Dec 21, 2017 - 01:46 PST