Service Status

Forum Upgrade
Incident Report for Poniverse
Resolved
The forums have been updated.
Posted 11 months ago. Jan 11, 2018 - 10:32 PST
Identified
MLPF is going offline for an upgrade! The upgrade will start at 10:30 AM PST (12:30 AM Central), and is expected to take about 5 minutes. The forum will be unavailable during that time.
Posted 11 months ago. Jan 11, 2018 - 10:03 PST