Service Status

Forum Upgrade
Incident Report for Poniverse
Resolved
The forums have been successfully upgraded.
Posted about 2 months ago. Apr 02, 2018 - 00:10 PDT
Investigating
MLPF is going offline for an upgrade! The upgrade will start at midnight, PST, and is expected to take about half an hour. The forum will be unavailable during that time.
Posted about 2 months ago. Apr 01, 2018 - 23:50 PDT