Service Status

MLP Forums upgrade
Incident Report for Poniverse
Resolved
Aaand we're back! Enjoy everypony ^_^ ~tinker
Posted 3 months ago. Apr 28, 2017 - 18:23 PDT
Investigating
A planned upgrade to MLPF is taking longer than expected. Bear with us as our tech ponies work away. ~tinker
Posted 3 months ago. Apr 28, 2017 - 18:22 PDT